Age of Valor
login.php?sid=25df9bb0b4d2e47f8b8986fccdacad3a profile.php?mode=register&sid=25df9bb0b4d2e47f8b8986fccdacad3a faq.php?sid=25df9bb0b4d2e47f8b8986fccdacad3a memberlist.php?sid=25df9bb0b4d2e47f8b8986fccdacad3a search.php?sid=25df9bb0b4d2e47f8b8986fccdacad3a index.php?sid=25df9bb0b4d2e47f8b8986fccdacad3a
Site Links: Home :: Donate :: Features :: Connection Guide




Age of Valor Forum Index » Bug Reports » Casting Bug Goto page 1, 2  Next
Post new topic  Reply to topic View previous topic :: View next topic 
Casting Bug
PostPosted: Tue Jul 04, 2017 2:32 am Reply with quote
Shanks
Joined: 07 Oct 2009
Posts: 219
Location: Leavittsburg, OH




Currently getting a bug where my casting isn't being counted?

I have 3/8 so 2/6 with magery but im casting as if i have 0/0

Character Corrupted Spawns
_________________
View user's profile Send private message AIM Address MSN Messenger
PostPosted: Tue Jul 04, 2017 3:16 am Reply with quote
Shanks
Joined: 07 Oct 2009
Posts: 219
Location: Leavittsburg, OH




Could also be odd server latency?
_________________
View user's profile Send private message AIM Address MSN Messenger
PostPosted: Wed Jul 05, 2017 12:51 pm Reply with quote
Shanks
Joined: 07 Oct 2009
Posts: 219
Location: Leavittsburg, OH




bump still having this problem, not sure whats causing this. makes my mages unplayable.
_________________
View user's profile Send private message AIM Address MSN Messenger
PostPosted: Wed Jul 05, 2017 6:11 pm Reply with quote
Death
AoV Administrator
Joined: 13 Dec 2006
Posts: 6402




Hmmm can you try taking your equipment off and logging in and out to see if it resolves when you put your equip back on?
View user's profile Send private message
PostPosted: Wed Jul 05, 2017 8:26 pm Reply with quote
Shanks
Joined: 07 Oct 2009
Posts: 219
Location: Leavittsburg, OH




basically ive done this on multiple characters as well as had bubbles confirm his casting is also not counting or there is server latency. personally im leaning towards server latency as ive had encounters where all combat freezes, including spell casting and mobs but i can move around freely. Not completely sure of the issue
_________________
View user's profile Send private message AIM Address MSN Messenger
PostPosted: Wed Jul 05, 2017 10:59 pm Reply with quote
ggkthx
Joined: 13 Jan 2009
Posts: 894
Location: MN




I'm not noticing an issue with casting right now, that I can tell.
But I am seeing intermittent server freezes of 20 sec or so.
It's like I'm lagging, except nothing around me moves or happens either, and then it eventually goes back to normal. I haven't paid attention to how frequently this was happening though.
It was 2 or 3 times in the 15-20 min I have been actively playing just now.
_________________

I didn't choose the Fel life, the Fel life chose me.
View user's profile Send private message Visit poster's website AIM Address
PostPosted: Fri Jul 07, 2017 1:23 am Reply with quote
Shanks
Joined: 07 Oct 2009
Posts: 219
Location: Leavittsburg, OH




bumping this again, casting is affected on all characters including my archers with chivalry. this is extremely impactful.
_________________
View user's profile Send private message AIM Address MSN Messenger
PostPosted: Fri Jul 07, 2017 1:28 am Reply with quote
Red Squirrel
AoV Owner
Joined: 13 Dec 2006
Posts: 8106
Location: Ontario, Canada




ggkthx wrote:
I'm not noticing an issue with casting right now, that I can tell.
But I am seeing intermittent server freezes of 20 sec or so.
It's like I'm lagging, except nothing around me moves or happens either, and then it eventually goes back to normal. I haven't paid attention to how frequently this was happening though.
It was 2 or 3 times in the 15-20 min I have been actively playing just now.


Hmm that's not good... Maybe it's just because the shard has not been rebooted in so long. I might try rebooting it later. Maybe the whole VM too as the uptime is probably in the 100's of days and that is kinda pushing it for Windows. Razz
_________________

my blog

Honk if you love Jesus, text if you want to meet Him!
View user's profile Send private message Visit poster's website MSN Messenger
PostPosted: Fri Jul 07, 2017 8:57 pm Reply with quote
Shanks
Joined: 07 Oct 2009
Posts: 219
Location: Leavittsburg, OH




Red Squirrel wrote:
ggkthx wrote:
I'm not noticing an issue with casting right now, that I can tell.
But I am seeing intermittent server freezes of 20 sec or so.
It's like I'm lagging, except nothing around me moves or happens either, and then it eventually goes back to normal. I haven't paid attention to how frequently this was happening though.
It was 2 or 3 times in the 15-20 min I have been actively playing just now.


Hmm that's not good... Maybe it's just because the shard has not been rebooted in so long. I might try rebooting it later. Maybe the whole VM too as the uptime is probably in the 100's of days and that is kinda pushing it for Windows. :P


I'm nearly certain this is the cause, I have normal casting on TC1 and it was recently refreshed.
_________________
View user's profile Send private message AIM Address MSN Messenger
PostPosted: Sat Jul 08, 2017 1:33 am Reply with quote
ggkthx
Joined: 13 Jan 2009
Posts: 894
Location: MN




Something something something, hax.
_________________

I didn't choose the Fel life, the Fel life chose me.
View user's profile Send private message Visit poster's website AIM Address
PostPosted: Wed Aug 16, 2017 6:58 pm Reply with quote
dprantl
Joined: 08 Feb 2007
Posts: 1075




I'm seeing the casting issue... sometimes it is better, sometimes worse. I also see the server freezes.
View user's profile Send private message
PostPosted: Thu Aug 17, 2017 4:42 am Reply with quote
Red Squirrel
AoV Owner
Joined: 13 Dec 2006
Posts: 8106
Location: Ontario, Canada




Hmm actually if I recall the random freezes were in fact an issue for a very long time, they are hit and miss. Has to do with new SQL system as it involves a lot of memory allocation/deallocation just because of how it works (it basically caches the queries in an array then another thread takes over to submit them - this is to ensure it does not access objects that may change). The freezes are caused by the garbage collector I presume but I was never able to pin point that 100%. I think adding more ram may possibly solve the issue, though I already allocated quite a lot of ram to the VM, I think it's at like 8GB.

I might look at scheduling a daily reboot, to see if that makes things better. The freezes may get worse over time as the shard runs longer so that may at least help the issue.

Can maybe look at some SQL system tweaks too, given the traffic is fairly low, I can probably get away with slowing down the queue processing interval and snap shot rate. There's a few values I can tweak to see if it makes things better.
_________________

my blog

Honk if you love Jesus, text if you want to meet Him!
View user's profile Send private message Visit poster's website MSN Messenger
PostPosted: Thu Aug 17, 2017 3:58 pm Reply with quote
dprantl
Joined: 08 Feb 2007
Posts: 1075




The freezes I can handle since the entire shard stops which makes it equal for everyone. It's the casting slow-down that is a real bitch and greatly affects gameplay.
View user's profile Send private message
PostPosted: Thu Aug 17, 2017 11:43 pm Reply with quote
Red Squirrel
AoV Owner
Joined: 13 Dec 2006
Posts: 8106
Location: Ontario, Canada




Hmm so when casting slows down, it's not the whole shard freezing too? This may be a separate issue, I will need to figure that one out. Is the casting slow in general or just randomly?

Is this something fairly new or has it been that way for a long time? Trying to think of any changes that may could have caused it.
_________________

my blog

Honk if you love Jesus, text if you want to meet Him!
View user's profile Send private message Visit poster's website MSN Messenger
PostPosted: Tue Sep 05, 2017 3:16 pm Reply with quote
dprantl
Joined: 08 Feb 2007
Posts: 1075




Right now I am casting Heal and it is taking ~2 seconds to complete a single one with 4/7 FC/FCR. It doesn't look like the shard is experiencing any freezes ATM. Removing equipped items to 0/0 FC/FCR hardly makes any difference in casting speed. Not sure when this started happening.
View user's profile Send private message
Casting Bug
Age of Valor Forum Index » Bug Reports
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT  
Page 1 of 2  
Goto page 1, 2  Next
  
  
 Post new topic  Reply to topic  
Shout Box


Powered by phpBB © 2001-2004 phpBB Group
Designed for Trushkin.net | Themes Database

This website and forum best viewed in a standards compliant browser such as Firefox or Opera.
Internet explorer is not recommended.